php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #45618 Insufficient filename sanitation (man pages)
Submitted: 2008-07-24 20:19 UTC Modified: 2008-07-24 21:08 UTC
From: hannes dot magnusson at gmail dot com Assigned: loudi (profile)
Status: Closed Package: Doc Build problem
PHP Version: Irrelevant OS: Linux
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: hannes dot magnusson at gmail dot com
New email:
PHP Version: OS:

 

 [2008-07-24 20:19 UTC] hannes dot magnusson at gmail dot com
Description:
------------
The man output format (PhD 0_2) doesn't sanitize filenames correctly; maxdb().3




Reproduce code:
---------------
phd -tmanpage -tphpfunctions -d.manual.xml
ls man/maxdb*



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-07-24 21:08 UTC] loudi@php.net
This bug has been fixed in CVS. Since the websites are not directly
updated from the CVS server, the fix might need some time to spread
across the globe to all mirror sites, including PHP.net itself.

Thank you for the report, and for helping us make PHP.net better.

fixed (no more () at the end of man pages filenames)
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Fri May 24 03:01:26 2019 UTC