php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #45570 PhD doesn't use the <colspec> "align" attribute in xhtml output
Submitted: 2008-07-20 14:55 UTC Modified: 2009-01-02 00:40 UTC
From: loudi@php.net Assigned: bjori (profile)
Status: Closed Package: Doc Build problem
PHP Version: Irrelevant OS: Irrelevant
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: loudi@php.net
New email:
PHP Version: OS:

 

 [2008-07-20 14:55 UTC] loudi@php.net
Description:
------------
When adding align attribute in a <colspec> (in docbook5 /table/tgroup/), it's neither used as a <td> nor a <th> attribute. 

Reproduce code:
---------------
<table>
    <title>Resource-Parameter Matrix</title>
    <tgroup cols="5">
     <colspec colnum="1" colname="col1" align="center"/>
     <colspec colnum="2" colname="col2" align="center"/>
     <thead>
      <row>
       <entry colname="col2">Key</entry>
       <entry colname="col1">Value</entry>
      </row>
     </thead>
     <tbody>
      <row>
       <entry colname="col1">Foo</entry>
       <entry colname="col2">Bar</entry>
      </row>
     </tbody>
    </tgroup>
</table>

Expected result:
----------------
<table border="5">
    <caption><b>Foo table</b></caption>
    <colgroup>

     <col align="center" />
     <col align="center" />
     <thead valign="middle">
      <tr valign="middle">
       <th colspan="1" align="center">Key</th>
       <th colspan="1" align="center">Value</th>
      </tr>

     </thead>

     <tbody valign="middle" class="tbody">
      <tr valign="middle">
       <td colspan="1" rowspan="1" align="center">Foo</td>
       <td colspan="1" rowspan="1" align="center">Bar</td>
      </tr>

     </tbody>
    </colgroup>

</table>

Actual result:
--------------
<table border="5">
    <caption><b>Foo table</b></caption>
    <colgroup>

     <col align="center" />
     <col align="center" />
     <thead valign="middle">
      <tr valign="middle">
       <th colspan="1">Key</th>
       <th colspan="1">Value</th>
      </tr>

     </thead>

     <tbody valign="middle" class="tbody">
      <tr valign="middle">
       <td colspan="1" rowspan="1" align="left">Foo</td>
       <td colspan="1" rowspan="1" align="left">Bar</td>
      </tr>

     </tbody>
    </colgroup>

</table>


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-07-27 15:28 UTC] philip@php.net
Related bug:

  http://bugs.php.net/bug.php?id=45318
 [2009-01-02 00:40 UTC] bjori@php.net
This bug has been fixed in CVS. Since the websites are not directly
updated from the CVS server, the fix might need some time to spread
across the globe to all mirror sites, including PHP.net itself.

Thank you for the report, and for helping us make PHP.net better.


 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed Nov 30 13:05:54 2022 UTC