php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #45544 [DE] utf-8 encodet incorrectly
Submitted: 2008-07-17 13:32 UTC Modified: 2009-04-22 20:39 UTC
Votes:1
Avg. Score:4.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: nobs at nobswolf dot info Assigned: sammywg (profile)
Status: Closed Package: Translation problem
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: nobs at nobswolf dot info
New email:
PHP Version: OS:

 

 [2008-07-17 13:32 UTC] nobs at nobswolf dot info
Description:
------------
some pages of the  german documention show strange characters for umlauts

it seems they got encoded latin1..utf8 twice

Reproduce code:
---------------
look at the german documentation:

http://www.php.net/manual/de/pdo.installation.php

when switching the browser manually to latin-1 you can see for example:   

k?�¶nnen

it shows 4 "strange" bytes instead of the expected 2

Expected result:
----------------
example from the URL "PHP 5.1 und h?her auf Unix-Systemen"

Actual result:
--------------
example from the URL "PHP 5.1 und höher auf Unix-Systemen"

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-07-17 19:11 UTC] bjori@php.net
Reclassified.

 [2009-04-22 20:39 UTC] wiesemann@php.net
This bug has been fixed in the documentation's XML sources. Since the
online and downloadable versions of the documentation need some time
to get updated, we would like to ask you to be a bit patient.

Thank you for the report, and for helping us make our documentation better.

(Fixed on Jan 8 12:46:26 2009 UTC by sammywg.)
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed May 25 17:04:04 2022 UTC