php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #45493 gethostbynamel test should use canonical names
Submitted: 2008-07-12 14:45 UTC Modified: 2008-07-23 08:31 UTC
From: arnaud dot lb at gmail dot com Assigned:
Status: Closed Package: Network related
PHP Version: 5.2.6 OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: arnaud dot lb at gmail dot com
New email:
PHP Version: OS:

 

 [2008-07-12 14:45 UTC] arnaud dot lb at gmail dot com
Description:
------------
gethostbynamel test 
ext/standard/tests/network/gethostbynamel_error.phpt should use 
canonical name for the "Testing gethostbynamel() with an unknown 
host" test:

var_dump(gethostbynamel("unknownhost_zzz_xxx_yyy"));

unknownhost_zzz_xxx_yyy may be expanded to  
unknownhost_zzz_xxx_yyy._your_local_domain_ and resolv correctly, in 
which case the test fails, even if it is actually not a bug.

The test may use a canonical name (a dot at the end for the name), 
so that it will not be expanded, and never resolv:

var_dump(gethostbynamel("unknownhost_zzz_xxx_yyy."));



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-07-23 08:31 UTC] lbarnaud@php.net
This bug has been fixed in CVS.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.
 
Thank you for the report, and for helping us make PHP better.


 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Mon Jan 17 09:03:34 2022 UTC