php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #45492 All tests fail with --disable-xml
Submitted: 2008-07-12 14:34 UTC Modified: 2008-07-23 08:58 UTC
From: arnaud dot lb at gmail dot com Assigned:
Status: Closed Package: SOAP related
PHP Version: 5.2.6 OS:
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: arnaud dot lb at gmail dot com
New email:
PHP Version: OS:

 

 [2008-07-12 14:34 UTC] arnaud dot lb at gmail dot com
Description:
------------
When PHP compiled with --disable-xml, all SOAP tests are failing 
with the following error:

$ cat ext/soap/tests/schema/schema085.diff
001+ Fatal error: Call to undefined function xml_parser_create() 
in /tmp/php-5.2.6/ext/soap/tests/schema/test_schema.inc on line 64


Reproduce code:
---------------
./configure --disable-all --enable-soap --enable-cli --with-pcre-regex
make
make test

Expected result:
----------------
All SOAP tests using xml_* functions should be skipped when the xml 
parser extension is not loaded

Actual result:
--------------
SOAP tests are not skipped and fail

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-07-12 16:15 UTC] felipe@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php5.2-latest.tar.gz
 
For Windows (zip):
 
  http://snaps.php.net/win32/php5.2-win32-latest.zip

For Windows (installer):

  http://snaps.php.net/win32/php5.2-win32-installer-latest.msi

I can't reproduce:

configure: error: SOAP extension requires LIBXML extension, add --enable-libxml
 [2008-07-12 17:37 UTC] arnaud dot lb at gmail dot com
Sorry, the reproduce procedure was incomplete.

This configure line makes the bug reproducible:

./configure --disable-all --enable-libxml --enable-soap --enable-cli --with-pcre-regex

Then, run:

TESTS=ext/soap/tests/schema/*.phpt make test

I just tested with php5.2-latest.tar.gz.
 [2008-07-23 08:58 UTC] lbarnaud@php.net
This bug has been fixed in CVS.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.
 
Thank you for the report, and for helping us make PHP better.


 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Mon May 27 10:01:30 2024 UTC