php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #45476 Translation error in an example
Submitted: 2008-07-10 12:38 UTC Modified: 2008-07-13 11:27 UTC
From: bizoua_p at epitech dot net Assigned:
Status: Closed Package: Translation problem
PHP Version: Irrelevant OS: All
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: bizoua_p at epitech dot net
New email:
PHP Version: OS:

 

 [2008-07-10 12:38 UTC] bizoua_p at epitech dot net
Description:
------------
There is a exemple error in the french translation of the str_word_count page.

> http://fr.php.net/manual/fr/function.str-word-count.php

Reproduce code:
---------------
<?php

$str = "Salut l'ami, vous
        avez          une b3lle mine !"; // << 3

print_r(str_word_count($str, 1));
print_r(str_word_count($str, 2));
print_r(str_word_count($str, 1, '????3'));  // << 3

echo str_word_count($str);

?>


Expected result:
----------------
Array
(
    [0] => Salut
    [1] => l'ami
    [2] => vous
    [3] => avez
    [4] => une
    [5] => belle  << belle << b3lle
    [6] => mine
)


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-07-13 11:27 UTC] jsgoupil@php.net
This bug has been fixed in the documentation's XML sources. Since the
online and downloadable versions of the documentation need some time
to get updated, we would like to ask you to be a bit patient.

Thank you for the report, and for helping us make our documentation better.

I fixed also some errors in the index of the second array
 [2020-12-30 12:50 UTC] nikic@php.net
Automatic comment on behalf of jsgoupil
Revision: http://git.php.net/?p=doc/fr.git;a=commit;h=fbeb4b1c41c5121695c20e810fd86c998afa3543
Log: fix #45476
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Thu Jan 20 20:03:35 2022 UTC