php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #45429 move_uploaded_file is terminating my scripts
Submitted: 2008-07-03 20:11 UTC Modified: 2008-07-04 11:57 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: aatelfer at hotmail dot com Assigned:
Status: Not a bug Package: Filesystem function related
PHP Version: 5.2.6 OS: Apache/2.0.63 (Unix)
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: aatelfer at hotmail dot com
New email:
PHP Version: OS:

 

 [2008-07-03 20:11 UTC] aatelfer at hotmail dot com
Description:
------------
move_uploaded_file file has some error that causes my script to terminate. I don't get any errors at all. The script just ends.


Reproduce code:
---------------
function uploadfile($filename,$path)
{
   if(is_uploaded_file($_FILES[$filename]['tmp_name']))  {		  	 	 
		   move_uploaded_file($_FILES[$filename]['tmp_name'],$path);
		   
		   return true;
		  }
   return false;
}

Expected result:
----------------
function should return a true or false value

Actual result:
--------------
Scripts terminates without any error

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-07-03 23:49 UTC] aatelfer at hotmail dot com
Sorry, I did not install the GD library.
It caused a fatal error and the error was suppressed.
 [2008-07-04 07:54 UTC] jani@php.net
So the problem is gone?
 [2008-07-04 11:29 UTC] aatelfer at hotmail dot com
Yes it is. My apologies.
 [2008-07-04 11:57 UTC] johannes@php.net
Closing then.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sun Aug 09 09:01:24 2020 UTC