php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #45412 [FR] Error in ob_get_contents french example
Submitted: 2008-07-02 08:32 UTC Modified: 2008-07-02 16:59 UTC
From: j at darksage dot fr Assigned:
Status: Closed Package: Translation problem
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: j at darksage dot fr
New email:
PHP Version: OS:

 

 [2008-07-02 08:32 UTC] j at darksage dot fr
Description:
------------
Result of "example 1" in the French documentation of "ob_get_contents" is wrong.

Reproduce code:
---------------
<?php

ob_start();

echo "Bonjour ";

$out1 = ob_get_contents();

echo "le monde";

$out2 = ob_get_contents();

ob_end_clean();

var_dump($out1, $out2);
?>


Expected result:
----------------
string(8) "Bonjour "
string(16) "Bonjour le monde"

Actual result:
--------------
string(8) "Bonjour "
string(8) "le monde"

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-07-02 16:59 UTC] yannick@php.net
This bug has been fixed in the documentation's XML sources. Since the
online and downloadable versions of the documentation need some time
to get updated, we would like to ask you to be a bit patient.

Thank you for the report, and for helping us make our documentation better.


 [2020-12-30 12:50 UTC] nikic@php.net
Automatic comment on behalf of yannick
Revision: http://git.php.net/?p=doc/fr.git;a=commit;h=0e48cfdaa5275d4b767c6084aeeb372256900ebc
Log: fix bug #45412
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu Dec 02 06:03:34 2021 UTC