php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #45250 PHP Fails after IIS restart
Submitted: 2008-06-12 17:46 UTC Modified: 2008-07-03 17:41 UTC
Votes:4
Avg. Score:5.0 ± 0.0
Reproduced:2 of 2 (100.0%)
Same Version:2 (100.0%)
Same OS:1 (50.0%)
From: split63 at rcsis dot com Assigned: jmetric (profile)
Status: Not a bug Package: IIS related
PHP Version: 5.2.6 OS: Windows Server 2003
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: split63 at rcsis dot com
New email:
PHP Version: OS:

 

 [2008-06-12 17:46 UTC] split63 at rcsis dot com
Description:
------------
Using the current PHP Windows Installer on the PHP web site, PHP is freshly installed successfully.  All PHP files on our various websites work.  All is great.  However, if IIS is restarted or the system rebooted, PHP no longer functions.   PHP is no longer processed and PHP pages are treated as simple HTML pages.

Nothing is altered or changed from when the intall completes, the PHP pages are tested and the IIS is rebooted.  We do not edit the php.ini or any other file.

We have tried uninstalling PHP and deleting its directory, and rebooting, and then re-installing several times.  The results are the same each time.
We installed IIS SAPI module each time.




Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-06-12 18:21 UTC] split63 at rcsis dot com
The OS is windows Server 2003 with all the current available service packs and patches.
 [2008-06-19 23:22 UTC] clive at meteoric dot ltd dot uk
Had the same problem here on an identical set up.

I'm not 100% sure where the problem lies, however i've got it working after doing the following:

1) Uninstalled PHP, deleted c:\program files\php entirely, rebooted.
2) Reinstalled into c:\php rather than c:\program files\php
3) Added a PHPRC environment variable pointing to c:\PHP
4) Removed all the extns from the bottom of c:\php\php.ini, then rebooted.

This for me seemed to solve the problem.

I then added back all the extns i needed. A good tip was to run php.exe from the command line, as this throws up errors in php.ini in particular in regards to extns you're trying to load which have third party dll requirements which may be missing.

Not a solution i'm afraid, but it may shed a little light on the subject.

Clive
 [2008-07-02 18:50 UTC] split63 at rcsis dot com
[quote](1) Uninstalled PHP, deleted c:\program files\php entirely, rebooted.
2) Reinstalled into c:\php rather than c:\program files\php
3) Added a PHPRC environment variable pointing to c:\PHP
4) Removed all the extns from the bottom of c:\php\php.ini, then
rebooted.
[/quote]
clive,
I had already done #1 and #2 repeately.  I checked on the PHPRC and path variables, and both were already there and correct.
I don't have any "extras" at the end of the php.ini that I know of.

When I run php.exe from the CMD window, it does nothing.  I hit CTRL C and the prompt comes back

This is so frustrating.  I'm sure its some blasted windows issue.
 [2008-07-03 16:58 UTC] split63 at rcsis dot com
Ok, found the problem.  WIth the "new" version of PHP short scripting tags have been DISABLED!!!!!  That is <?  my code ?> are ignored.  Instead only the longer version are processed <?php  my code ?>

There is a php.ini variable that must be set to on.
 short_open_tag = on

This is complete BS, and this should by default be turned to on.
 [2008-07-03 17:41 UTC] pajoye@php.net
Not a bug > bogus.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Tue Jul 16 19:01:28 2024 UTC