php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #45246 make error after ./configure --with-mysql
Submitted: 2008-06-12 12:34 UTC Modified: 2009-04-28 01:00 UTC
From: benedikt at vamos-inc dot at Assigned:
Status: No Feedback Package: MySQL related
PHP Version: 6CVS-2008-06-12 (snap) OS: Debian etch
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: benedikt at vamos-inc dot at
New email:
PHP Version: OS:

 

 [2008-06-12 12:34 UTC] benedikt at vamos-inc dot at
Description:
------------
Hello,
Today I tried to compile and install the snapshot of PHP6. I got it running when i configured it with
"./configure --with-apxs2=/usr/bin/apxs2 --with-config-file-path=/etc/php5/apache2/php.ini".
But when I configure it with mysql (--with-mysql --with-mysqli ) I get the following error after "make":


/usr/include/mysql/mysql.h:295: error: expected specifier-qualifier-list before numeric constant
/usr/include/mysql/mysql.h:684: error: expected specifier-qualifier-list before numeric constant
make: *** [main/internal_functions.lo] Fehler 1


I didn't find a solution on the internet but this bug report for php5 http://bugs.php.net/bug.php?id=42890 so I thougth maybe this is a bug too.

(when I try it without mysql it works fine.)

best regards,
Benedikt

Reproduce code:
---------------
# ./configure --with-apxs2=/usr/bin/apxs2 --with-config-file-path=/etc/php5/apache2/php.ini --with-bz2 --enable-ftp --enable-zip --enable-shared --enable-mbstring=all --with-gd --with-mhash --with-mcrypt --withmime_magic --with-openssl --enable-posix --enable-session --enable-sockets --with-xsl  --with-zlib --with-freetype-dir  --with-png-dir --with-jpeg-dir --enable-gd-native-ttf  --with-curl --with-curlwrappers --with-libxml-dir --disable-mbregex --with-kerberos --with-imap --with-imap-ssl --with-mysql --with-mysqli --with-ldap --enable-exif

# make

Expected result:
----------------
i would except "make" without errors

Actual result:
--------------
error with "make" in mysql.h

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-06-12 12:53 UTC] felipe@php.net
What is the mysql lib version?
What is the gcc version?
 [2008-06-12 13:26 UTC] benedikt at vamos-inc dot at
hi!

gcc should be 4.1.2 20061115 (prerelease)

i installed mysql-server (5.0) and libmysqlclient-dev (should be libmysqlclient15-dev_5.0.32-7etch5_i386) through apt-get install (debian)
 [2009-04-20 18:20 UTC] jani@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php6.0-latest.tar.gz
 
For Windows:

  http://windows.php.net/snapshots/


 [2009-04-28 01:00 UTC] php-bugs at lists dot php dot net
No feedback was provided for this bug for over a week, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Fri Dec 09 05:05:53 2022 UTC