php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #45243 "configure" script fails with apxs2
Submitted: 2008-06-12 06:17 UTC Modified: 2016-12-31 00:22 UTC
Votes:3
Avg. Score:4.0 ± 0.8
Reproduced:3 of 3 (100.0%)
Same Version:2 (66.7%)
Same OS:2 (66.7%)
From: talltony at breakthru dot com Assigned:
Status: Open Package: *Configuration Issues
PHP Version: 5.2.6 OS: AIX 5.3
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: talltony at breakthru dot com
New email:
PHP Version: OS:

 

 [2008-06-12 06:17 UTC] talltony at breakthru dot com
Description:
------------
I'm trying to compile PHP 5.2.6 on AIX 5.3 with IBM HTTP Server (which is basically Apache/2.0.47).

When I run the supplied configure script as follows, I get the error below:
> ./configure --with-apxs2=/usr/ihs/bin/apxs
.
.
.
with_apxs2=/usr/ihs/bin/apxs
withval=/usr/ihs/bin/apxs
x_includes=NONE
x_libraries=NONE
expr: syntax error
configure: error: You have enabled Apache 2 support while your server is Apache 1.3.  Please use the appropiate switch --with-apxs (without the 2)

Basically, there seems to be a error in line 6707 where the script tries this:
APACHE_VERSION=`expr $4 \* 1000000 + $5 \* 1000 + $6`
($4, $5 and $6 have no values.)

I have tried using autoconfig to generate a new configuration file and which seems to work. However, when I try ' buildconf --force' it fails so I'm not comfortable using my version of configure in case buldconf performs any other magic.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2016-12-31 00:22 UTC] cmb@php.net
-Package: Feature/Change Request +Package: *Configuration Issues
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Thu Jun 20 06:01:27 2019 UTC