php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #45203 missing HTTP Vary header
Submitted: 2008-06-07 17:07 UTC Modified: 2009-06-16 06:03 UTC
From: e dot ehritt at web dot de Assigned:
Status: Closed Package: Zlib related
PHP Version: 5.2.6 OS: other
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: e dot ehritt at web dot de
New email:
PHP Version: OS:

 

 [2008-06-07 17:07 UTC] e dot ehritt at web dot de
Description:
------------
If configuration of zlib.output_compression
zlib.output_compression_level is seeded in a php.ini, not at all there are a header "Vary". RFC 2616 section 14.44 requires own.

It is the same problem as discribe in http://bugs.php.net/40325
ob_start('ob_gzhander') is not the only way to start output compression.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-06-09 08:47 UTC] jani@php.net
And as was mentioned in bug #40325, it was fixed in HEAD (as in: PHP 6) but the fix was not possible to be merged to 5.2 branch.
 [2008-06-10 10:54 UTC] e dot ehritt at web dot de
May you have kindness and have a look at source code? Thanks!

Now hander ob_gzhander sends the HTTP header. It shows you: It is possible to merge into 5.2. You are able to do so as well.
 [2008-06-10 23:35 UTC] jani@php.net
Feel free to provide a patch. Otherwise -> Wont fix. 
Do not reopen this before discussing with mike@php.net about it..
 [2008-06-11 17:35 UTC] e dot ehritt at web dot de
Last time when I brought you a patch the result was no fixing. Your reaction: Deleting the bug report and avoiding the problem own year later.

And now I, sorry _I_, have to turn to mike to help you again? I hope you are able to pick up my e-mail address form the messages, if you are interested getting a fix.

All is said.
 [2009-05-26 23:02 UTC] e dot ehritt at web dot de
It works now. Thanks, but why you fix it this way?

zlib.c

Use php_enable_output_compression() as standard out put only and put all HTTP staff into it call it from PHP_FUNCTION(ob_gzhandler). Status now is functionally a dupe of code lines:

970 -> 987 and 1059 -> 1075
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Tue Nov 24 20:01:23 2020 UTC