php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #45172 A fatal error is not thrown if an eroneous php is included
Submitted: 2008-06-04 12:11 UTC Modified: 2008-06-04 12:27 UTC
From: givanz at yahoo dot com Assigned:
Status: Not a bug Package: Output Control
PHP Version: 5.2.6 OS: Debian Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: givanz at yahoo dot com
New email:
PHP Version: OS:

 

 [2008-06-04 12:11 UTC] givanz at yahoo dot com
Description:
------------
The code is self explanatory

Reproduce code:
---------------
<?php
		include('include.php');
		echo 'This should not be echoed';
?>

include.php below

<?
fatalerror
?>

Expected result:
----------------
No output

Actual result:
--------------
the script echoes 'This should not be echoed'

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-06-04 12:27 UTC] msaraujo@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

http://br2.php.net/require
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sat May 28 05:09:35 2022 UTC