php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #45148 Configure should stop when endian is unknown
Submitted: 2008-06-02 11:52 UTC Modified: 2008-07-11 16:23 UTC
Votes:5
Avg. Score:3.8 ± 0.7
Reproduced:5 of 5 (100.0%)
Same Version:2 (40.0%)
Same OS:2 (40.0%)
From: ncoesel at dealogic dot nl Assigned:
Status: Wont fix Package: Compile Failure
PHP Version: 5.2.6 OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: ncoesel at dealogic dot nl
New email:
PHP Version: OS:

 

 [2008-06-02 11:52 UTC] ncoesel at dealogic dot nl
Description:
------------
I had the error "Balloc() allocation exceeds list boundary" on a MIPS big endian platform. It turns out configure cannot test for endiannes and sets ac_cv_c_bigendian_php to "unknown" which presumably defaults to little endian. IMHO configure should stop and produce a clear error to enforce a proper build environment.


Reproduce code:
---------------
<?php
phpinfo();
?>


Expected result:
----------------
Php info output

Actual result:
--------------
"Balloc() allocation exceeds list boundary" when trying to print the date.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-06-03 16:42 UTC] mike at w4g dot org
I just experienced a different result of the same problem on another big-endian cross compiled platform.  A floatval() conversion resulted in the CPU being pegged until the script hit the 30s timeout.  Doing some ptrace(GETREGS) sampling of the program counter showed the processor in pow5mult() and s2b().  Floating point constants were interpreted as -0 and floating point calculations would also wedge the CPU.

As a kludge setting 'ac_cv_c_bigendian_php=yes' in the environment before running configure got it working.

Debugging PHP on a stripped down embedded platform is not fun.  Configuring bombing out would have saved a few hours.
 [2008-07-11 09:29 UTC] rsxin at hotmail dot com
I have the same error running folling script under mips-64 platform:
 $this->time = date('H:i:s');
 [2008-07-11 16:23 UTC] jani@php.net
If you're cross-compiling PHP, you're on your own. We don't support nor try to support cross-compiling in any way. There's enough problems with "normal" compiling.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri Apr 10 10:01:24 2020 UTC