php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #45071 Links to require/include(_once) not rendered
Submitted: 2008-05-22 21:48 UTC Modified: 2008-10-19 17:14 UTC
From: colder@php.net Assigned: bjori (profile)
Status: Closed Package: Doc Build problem
PHP Version: Irrelevant OS: Irrelevant
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: colder@php.net
New email:
PHP Version: OS:

 

 [2008-05-22 21:48 UTC] colder@php.net
Description:
------------
It seems like links between include/require(_once) are not rendered:
i.e. http://docs.php.net/require (page itself along with See also:..)


Reproduce code:
---------------
foo

Expected result:
----------------
links

Actual result:
--------------
no links


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-05-22 21:57 UTC] philip@php.net
For some history: this was once a bug, then fixed (in xslt), and now it's a bug again (in phd).

  http://bugs.php.net/bug.php?id=40650
 [2008-10-19 17:14 UTC] bjori@php.net
This bug has been fixed in CVS. Since the websites are not directly
updated from the CVS server, the fix might need some time to spread
across the globe to all mirror sites, including PHP.net itself.

Thank you for the report, and for helping us make PHP.net better.

This is because include/require[_once] and return are not documented as refentries.

A workaround for this issue has been committed.
 [2009-10-09 02:27 UTC] svn@php.net
Automatic comment from SVN on behalf of moacir
Revision: http://svn.php.net/viewvc/?view=revision&revision=289395
Log: Fixing bug #45071.
Added methods in the Format class to extend the index information:
- addRefname
- addClassname
- addVarname
 [2009-10-09 23:34 UTC] svn@php.net
Automatic comment from SVN on behalf of moacir
Revision: http://svn.php.net/viewvc/?view=revision&revision=289453
Log: Adding notes for the last fixes:
- Bug #45071
- Bug #49743
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Tue May 11 00:01:23 2021 UTC