php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #45056 gd image stream support
Submitted: 2008-05-21 10:14 UTC Modified: 2008-05-21 11:04 UTC
From: goetas at lignano dot it Assigned: pajoye (profile)
Status: Not a bug Package: Streams related
PHP Version: 5.2.6 OS: Windows XP
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: goetas at lignano dot it
New email:
PHP Version: OS:

 

 [2008-05-21 10:14 UTC] goetas at lignano dot it
Description:
------------
missing stream  (or user stream wrapper )support

Reproduce code:
---------------
<?
$im = imagecreate();
imagejpeg($im,'php://output'); // or imagejpeg($im,'var://myvar');
?>

Expected result:
----------------
image sent to stdout or into $myvar 

Actual result:
--------------
Warning: imagejpeg() [function.imagejpeg]: Unable to open 'php://output' for writing: No such file or directory in ...

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-05-21 11:04 UTC] pajoye@php.net
duplicate of #39263
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Wed Oct 23 21:01:33 2019 UTC