php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #44915 ip2long
Submitted: 2008-05-05 12:06 UTC Modified: 2008-05-06 19:50 UTC
From: sascha at rizzt dot kicks-ass dot org Assigned:
Status: Closed Package: Unknown/Other Function
PHP Version: 5.2.6 OS: Linux 2.6.24.3-34.fc8 #1
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: sascha at rizzt dot kicks-ass dot org
New email:
PHP Version: OS:

 

 [2008-05-05 12:06 UTC] sascha at rizzt dot kicks-ass dot org
Description:
------------
Since quite a while i see ips like 127.255.255.255

the ips in the logfile are correct, but ip2long doesn't convert it correctly.

i cannot reproduce the bug with a simple script.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-05-05 12:25 UTC] derick@php.net
Thank you for this bug report. To properly diagnose the problem, we
need a short but complete example script to be able to reproduce
this bug ourselves. 

A proper reproducing script starts with <?php and ends with ?>,
is max. 10-20 lines long and does not require any external 
resources such as databases, etc. If the script requires a 
database to demonstrate the issue, please make sure it creates 
all necessary tables, stored procedures etc.

Please avoid embedding huge scripts into the report.
 [2008-05-06 19:50 UTC] sascha at rizzt dot kicks-ass dot org
mysql issue, the new version doesnt convert unsigned to signed anymore and cuts the value
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Thu May 19 18:03:41 2022 UTC