php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #44914 Array index access with invalid keys on strings without consequences
Submitted: 2008-05-05 10:52 UTC Modified: 2008-05-05 11:28 UTC
From: sgalonska at studivz dot net Assigned:
Status: Not a bug Package: Strings related
PHP Version: 5.2.6 OS: UNIX
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: sgalonska at studivz dot net
New email:
PHP Version: OS:

 

 [2008-05-05 10:52 UTC] sgalonska at studivz dot net
Description:
------------
It is allowed to access a string the same way as an array. So it is obvious to imply that using numeric indexes is the only way to achieve that goal. Unfortunately access over alphanumeric keys is also possible. In that case, PHP converts them into 0. This behavior seems to be a bug since no notice or error is risen.

Reproduce code:
---------------
$string = 'abcdefghijk';
print $string[0] . PHP_EOL;
print $string['foo'] . PHP_EOL;

Expected result:
----------------
a
<some error about wrong access mode or invalid index>


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-05-05 11:29 UTC] msaraujo@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sun Dec 15 04:01:23 2019 UTC