php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #44829 German do ... while; desc incomplete
Submitted: 2008-04-25 11:13 UTC Modified: 2008-05-02 21:41 UTC
Votes:1
Avg. Score:1.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: kuebel at lehrer dot cc Assigned:
Status: Closed Package: Translation problem
PHP Version: Irrelevant OS: -
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: kuebel at lehrer dot cc
New email:
PHP Version: OS:

 

 [2008-04-25 11:13 UTC] kuebel at lehrer dot cc
Description:
------------
do while - documentation:
http://at2.php.net/manual/de/control-structures.do.while.php

English:
Advanced C users may be familiar with a different usage of the do-while loop, to allow stopping execution in the middle of code blocks, by encapsulating them with do-while (0), and using the break statement. 

German:
Erfahrene C-Anwender kennen auch die M?glichkeit, Programm-Bl?cke mit do-while (0) einzuschliessen und dann die break Anweisung zu benutzen.

German version does not explain why to use this construct, making it difficult to understand for non-advanced users.

Add for example after "benutzen":
, um einen Programmblock auch in der Mitte verlassen zu k?nnen.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-05-02 21:41 UTC] fa@php.net
This bug has been fixed in the documentation's XML sources. Since the
online and downloadable versions of the documentation need some time
to get updated, we would like to ask you to be a bit patient.

Thank you for the report, and for helping us make our documentation
better.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Tue Nov 30 16:03:36 2021 UTC