php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #44760 The info test page works once, then fails.
Submitted: 2008-04-17 13:49 UTC Modified: 2008-10-21 11:29 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: ahorwitz at numoda dot com Assigned:
Status: Wont fix Package: IIS related
PHP Version: 5.2.5 OS: XP
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: ahorwitz at numoda dot com
New email:
PHP Version: OS:

 

 [2008-04-17 13:49 UTC] ahorwitz at numoda dot com
Description:
------------
Trying to install PHP 5 on XP with IIS. The following page runs once, then fails when refresh is clicked. If I close the browser and try the page again, the page loads once, then fails on refresh.

Reproduce code:
---------------
<?php
  session_start();
?>
<html>
  <head>
    <title>PHP Test</title>
  </head>
  <body>
    <p>
      The browser you're using is 
      <?php echo $_SERVER['HTTP_USER_AGENT']; ?>
    </p>
    <p>
      <!-- test the browscap setup -->
      Your browser's capabilities are: <br/>
      <pre>
        <?php print_r(get_browser(null, true)); ?>
      </pre>
    </p>
    <?php phpinfo(); ?>
  </body>
</html>
	

Expected result:
----------------
It should work more than once without closing and opening my web browser.

Actual result:
--------------
Page just attempts to load.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-04-18 12:58 UTC] ahorwitz at numoda dot com
I installed PHP exactly the way the php.net instructions told me to do. It is a brand new machine with a clean install of Windows XP. Also, I am able to stop and start the web site through the IIS Management console. But, IIS crashes if I try to stop and start World Wide Web Services from the services management console. Is PHP 5 just completely unstable in a Windows XP/IIS 5 environment? Any comments would be appreciated.
 [2008-10-21 11:29 UTC] jani@php.net
Use FastCGI instead.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Wed May 27 14:01:22 2020 UTC