php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #44746 SoapFault: Only http and https are allowed
Submitted: 2008-04-16 18:20 UTC Modified: 2008-10-21 11:29 UTC
Votes:2
Avg. Score:5.0 ± 0.0
Reproduced:2 of 2 (100.0%)
Same Version:2 (100.0%)
Same OS:2 (100.0%)
From: rbrodka at kraftmaid dot com Assigned:
Status: Not a bug Package: SOAP related
PHP Version: 5.2.5 OS: Windows Server 2003 Std
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: rbrodka at kraftmaid dot com
New email:
PHP Version: OS:

 

 [2008-04-16 18:20 UTC] rbrodka at kraftmaid dot com
Description:
------------
This seems to be the same error as bug #42637, but I got it on Windows Server 2003 Standard and PHP version 5.2.5.

I received the following error when trying to execute a soap client function (invokeService):

Fatal error: SOAP Fault: (faultcode: HTTP, faultstring: Unknown protocol. Only http and https are allowed.) in C:\randall\grid.php on line 36


The following functions work fine:
var_dump($client->__getFunctions());
var_dump($client->__getTypes());


Reproduce code:
---------------
try {
	$wsdl   = 'http://KM2BPM1/ApplicationServiceGateway.wsdl';
	$client = new SoapClient($wsdl); 
	$params = array();
	$params['commandLine'] = 'GET.PHONE.EXTENSION.FOR.USER USER=rbrodka';
	$params['options']     = '';
	echo $client->invokeService($params);
} catch (SoapFault $fault) {
   trigger_error("SOAP Fault: (faultcode: {$fault->faultcode}, faultstring: {$fault->faultstring})", E_USER_ERROR);
}

Expected result:
----------------
I expected the code to execute without triggering an error.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-10-21 11:29 UTC] jani@php.net
Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. 

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sat Jan 22 03:03:33 2022 UTC