php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #44745 child pid 913624 exit signal Segmentation fault (11)
Submitted: 2008-04-16 17:21 UTC Modified: 2008-07-11 21:41 UTC
From: mssanch2002 at yahoo dot com Assigned:
Status: Wont fix Package: Reproducible crash
PHP Version: 4.4.8 OS: aix 5.3
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: mssanch2002 at yahoo dot com
New email:
PHP Version: OS:

 

 [2008-04-16 17:21 UTC] mssanch2002 at yahoo dot com
Description:
------------
I configure apache 1.4.41 with the following config:

/configure --with-layout=Apache --prefix=/macs/apache --activate-module=src/modules/php4/libphp4.a

I receive the following message in apache error_log when I use the browser:

child pid 913624 exit signal Segmentation fault (11)



Actual result:
--------------
GNU gdb 6.0
Copyright 2003 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "powerpc-ibm-aix5.1.0.0"...
(no debugging symbols found)...
(gdb) run -X
Starting program: /macs/apache_1.3.41/bin/httpd -X

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 1]
0x1007de4c in ?? ()
(gdb) bt
#0  0x1007de4c in ?? ()
(gdb)

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-04-16 18:26 UTC] mssanch2002 at yahoo dot com
PHP was configured with the following:

./configure  --with-oci8 --without-mysql --with-apache=../apache --enable-debug
 [2008-04-17 12:33 UTC] mssanch2002 at yahoo dot com
I'm also getting these warning when I run the make.

/macs/php-4.4.8/ext/standard/info.c: In function 'php_info_write_wrapper':
/macs/php-4.4.8/ext/standard/info.c:69: warning: pointer targets in passing argu
ment 1 of 'php_escape_html_entities' differ in signedness
/macs/php-4.4.8/ext/standard/info.c: In function 'php_info_html_esc':
/macs/php-4.4.8/ext/standard/info.c:216: warning: pointer targets in passing arg
ument 1 of 'php_escape_html_entities' differ in signedness
/macs/php-4.4.8/ext/standard/info.c: In function 'php_print_info':
/macs/php-4.4.8/ext/standard/info.c:506: warning: pointer targets in passing arg
ument 3 of 'zend_hash_get_current_key_ex' differ in signedness
/macs/php-4.4.8/ext/standard/info.c: At top level:
/macs/php-4.4.8/TSRM/tsrm_virtual_cwd.h:166: warning: 'php_realpath_hack' define
d but not used
 [2008-04-18 21:18 UTC] mssanch2002 at yahoo dot com
I found out that the problem was compiling using oracle 10.2.0.3.0 libraries. When I use oracle 9.2.0, I do not get the segmentation faults. Does anyone know about this problem?
 [2008-07-11 21:41 UTC] jani@php.net
We are sorry, but we can not support PHP 4 related problems anymore.
Momentum is gathering for PHP 6, and we think supporting PHP 4 will
lead to a waste of resources which we want to put into getting PHP 6
ready.


 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Mon Mar 08 07:01:23 2021 UTC