php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #44727 PHP installs but will not serve pages
Submitted: 2008-04-14 21:23 UTC Modified: 2008-10-21 11:29 UTC
Votes:3
Avg. Score:4.0 ± 1.4
Reproduced:3 of 3 (100.0%)
Same Version:2 (66.7%)
Same OS:2 (66.7%)
From: stevenhunt_ at hotmail dot com Assigned:
Status: Wont fix Package: IIS related
PHP Version: 5.2.5 OS: Windows Vista Ultimate 64bit
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: stevenhunt_ at hotmail dot com
New email:
PHP Version: OS:

 

 [2008-04-14 21:23 UTC] stevenhunt_ at hotmail dot com
Description:
------------
After successfully installing PHP i ryed to run a basic php info page and got an extension error.

as best i can see this is due to it beinf a 32bit application but changeing the proccess thread to allow 32 bit applications then causes a service unavailable and crashed the process thread.

Reproduce code:
---------------
install and try PHP on vista ultimate 64bit edition.

Expected result:
----------------
phpinfo() to execute and pages to run

Actual result:
--------------
HTTP Error 500.21 - Internal Server Error
Handler "PHP-ISAPI" has a bad module "IsapiModule" in its module list

Module IIS Web Core 
Notification ExecuteRequestHandler 
Handler PHP-ISAPI 
Error Code 0x8007000d 
Requested URL http://localhost:80/info.php 
Physical Path C:\inetpub\wwwroot\info.php 
Logon Method Anonymous 
Logon User Anonymous 


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-10-21 11:29 UTC] jani@php.net
use the fastcgi instead.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Thu Dec 03 10:01:24 2020 UTC