php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #44675 no output from exec()
Submitted: 2008-04-08 21:44 UTC Modified: 2008-04-08 22:15 UTC
From: lagunaloire at argentina dot com Assigned:
Status: Not a bug Package: Output Control
PHP Version: 5.2.5 OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: lagunaloire at argentina dot com
New email:
PHP Version: OS:

 

 [2008-04-08 21:44 UTC] lagunaloire at argentina dot com
Description:
------------
The exec() function does not fill the &$output array!
I don't get the output from any program what I try to execute in Safe mode or not.

Reproduce code:
---------------
exec("program", $output);
print_r($output);

Expected result:
----------------
Array
(
  [0] => line1
  [1] => line2
  [2] => line3
)

Actual result:
--------------
Array () sometimes or nothing at all.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-04-08 22:01 UTC] lagunaloire at argentina dot com
A compilation problem. First I was compiled apache newly and forget to recompile PHP. I recompiled PHP and it is working now.
 [2008-04-08 22:06 UTC] lagunaloire at argentina dot com
Not not! I mistake! I just put something in the array like this:
$output=array("nothing here", "nothing there");
And I see that but that does not mean what I'm seing that from the program what I executed! Just I was seing it from the self php script.
Sorry!! =S It is not working still! I don't get filled the array with the output for the external program.
 [2008-04-08 22:11 UTC] lagunaloire at argentina dot com
I found the problem. The problem is YOU CANNOT CALL exec() FROM A REQUIRED PHP. That mean if you require("somepage.php"); in somepage.php you cannot call exec();
 [2008-04-08 22:15 UTC] lagunaloire at argentina dot com
Newly. To call exec from "some.php" you cannot do a require in this manner:
chdir("somedir");
require("some.php");

You must do it in this manner:
require("somedir/some.php");

And exec() will work in "some.php".
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Tue Apr 23 18:01:34 2024 UTC