php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #4457 Comiling with oci8
Submitted: 2000-05-15 16:29 UTC Modified: 2006-07-17 08:08 UTC
From: bakins at stsi dot net Assigned:
Status: Closed Package: OCI8 related
PHP Version: 4.0 Release Candidate 2 OS: Solaris 8
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: bakins at stsi dot net
New email:
PHP Version: OS:

 

 [2000-05-15 16:29 UTC] bakins at stsi dot net
I had some trouble compiling 4.0 RC2 with oci8.  I was using:
Solaris 8
Oracle 8.1.5
gcc 2.9.5.2

It failed to compile complaining that nzt.h was not found.  I finally fixed it
by adding "-I/my/oracle/home/netwok/public" to the oci section of the
config_vars.mk file.  I know this isn't the best way to do it, but it worked.

I don't think configure is adding all the oracle includes it should.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-07-25 23:40 UTC] zak@php.net
Please try compiling a more recent release of php.  If you encounter problems, please submit a new bug report.

Thank you!
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Fri May 24 07:01:26 2019 UTC