php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #44535 Documentation on Session: don't assume session support is compiled in
Submitted: 2008-03-25 23:31 UTC Modified: 2008-10-25 12:46 UTC
From: glenn at opengate dot be Assigned: kalle (profile)
Status: Not a bug Package: Documentation problem
PHP Version: Irrelevant OS: Arch Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: glenn at opengate dot be
New email:
PHP Version: OS:

 

 [2008-03-25 23:31 UTC] glenn at opengate dot be
Description:
------------
http://www.php.net/session says this:
"Session support is enabled in PHP by default.".

However, this is not always the case, session support can easily be compiled as a module. Therefore the documentation should be changed to reflect this, indicating if session support was compiled as a module it should be dl()'ed or added as extension=session.so in php.ini


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-10-25 12:46 UTC] kalle@php.net
By the term "enabled in PHP by default" it means when you run a "./configure" it will automaticlly enable ext/session rather than having to "./configure --enable-session".

Its up to the users to detect whenever session support is enabled or not since its not apart of the standard library that comes with php nor is it one of the extensions that cannot be disabled. So this is bogus :)
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri Oct 30 02:01:24 2020 UTC