php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #44531 forgot "}"
Submitted: 2008-03-25 14:48 UTC Modified: 2008-03-25 15:58 UTC
From: php at manitu-wolf dot de Assigned:
Status: Closed Package: Translation problem
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: php at manitu-wolf dot de
New email:
PHP Version: OS:

 

 [2008-03-25 14:48 UTC] php at manitu-wolf dot de
Description:
------------
at the german version of "break", you forgot a "}" at the end of first while

hope this is the right section for it

Reproduce code:
---------------
http://us3.php.net/manual/de/control-structures.break.php

Expected result:
----------------
<?php
$arr = array('eins', 'zwei', 'drei', 'vier', 'stop', 'f?nf');
while (list ( , $val) = each ($arr)) {
    if ($val == 'stop') {
        break;  /* Sie k?nnten hier auch 'break 1;' schreiben. */
    }
    echo "$val<br />\n";
}

/* Benutzung des optionalen Argumentes. */

$i = 0;
while (++$i) {
    switch ($i) {
    case 5:
        echo "Bei 5<br />\n";
        break 1;  /* Beendet nur switch. */
    case 10:
        echo "Bei 10; aussteigen<br />\n";
        break 2;  /* Beendet switch und while. */
    default:
        break;
    }
}
?>

Actual result:
--------------
<?php
$arr = array('eins', 'zwei', 'drei', 'vier', 'stop', 'f?nf');
while (list ( , $val) = each ($arr)) {
    if ($val == 'stop') {
        break;  /* Sie k?nnten hier auch 'break 1;' schreiben. */
    }
    echo "$val<br />\n";

/* Benutzung des optionalen Argumentes. */

$i = 0;
while (++$i) {
    switch ($i) {
    case 5:
        echo "Bei 5<br />\n";
        break 1;  /* Beendet nur switch. */
    case 10:
        echo "Bei 10; aussteigen<br />\n";
        break 2;  /* Beendet switch und while. */
    default:
        break;
    }
}
?>

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-03-25 15:58 UTC] danbrown@php.net
This bug has been fixed in the documentation's XML sources. Since the
online and downloadable versions of the documentation need some time
to get updated, we would like to ask you to be a bit patient.

Thank you for the report, and for helping us make our documentation better.

Thanks for submitting this bug report.  The documentation has been fixed in CVS and will update on the web soon.

~ Dan Brown
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Tue Jan 18 03:03:35 2022 UTC