php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #44464 cannot get an INTEL image 64 bits
Submitted: 2008-03-18 06:50 UTC Modified: 2008-03-25 13:43 UTC
From: ingconti at ingconti dot com Assigned:
Status: Not a bug Package: Dynamic loading
PHP Version: 5.2.5 OS: osx 10.5
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: ingconti at ingconti dot com
New email:
PHP Version: OS:

 

 [2008-03-18 06:50 UTC] ingconti at ingconti dot com
Description:
------------
I downloaded .tar and tried to compile for osx 10.5.

it works but issuing make install:

<b>
cp libs/libphp5.so /usr/libexec/apache2/libphp5.so
Warning!  dlname not found in /usr/libexec/apache2/libphp5.so.
Assuming installing a .so rather than a libtool archive.
chmod 755 /usr/libexec/apache2/libphp5.so
</b>

and launching apache:

<b>
apachectl -t
</b>
httpd: Syntax error on line 117 of /private/etc/apache2/httpd.conf: 
Cannot load /usr/libexec/apache2/libphp5.so into server: 
dlopen(/usr/libexec/apache2/libphp5.so, 10): no suitable image found.  
Did find:\n\t/usr/libexec/apache2/libphp5.so: mach-o, but wrong 
architecture









Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-03-18 07:16 UTC] ingconti at ingconti dot com
comapring Apple original and version compiled:

file libphp5.so
libphp5.so: Mach-O bundle i386

file libphp5_APPLE.so
libphp5_APPLE.so: Mach-O universal binary with 4 architectures
libphp5_APPLE.so (for architecture ppc7400):	Mach-O bundle ppc
libphp5_APPLE.so (for architecture ppc64):	Mach-O 64-bit bundle 
ppc64
libphp5_APPLE.so (for architecture i386):	Mach-O bundle i386
libphp5_APPLE.so (for architecture x86_64):	Mach-O 64-bit bundle 
x86_64
 [2008-03-25 13:43 UTC] jani@php.net
You need to pass several different CFLAGs to achieve this. Here's some help, google for more yourself (this is not a bug!):

http://blog.liip.ch/archive/2005/06/08/universal-binary-php.html

 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sun Mar 03 22:01:27 2024 UTC