php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #44452 French translation - problems with sprintf()
Submitted: 2008-03-17 09:18 UTC Modified: 2008-03-25 00:02 UTC
From: rodolphe dot breard at etu dot univ-nantes dot fr Assigned:
Status: Closed Package: Translation problem
PHP Version: Irrelevant OS: Any
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: rodolphe dot breard at etu dot univ-nantes dot fr
New email:
PHP Version: OS:

 

 [2008-03-17 09:18 UTC] rodolphe dot breard at etu dot univ-nantes dot fr
Description:
------------
There's some mistakes with the French translation of sprintf().

Problem in example 3 :
 - There is 2 unwanted \ (line 2)

Problem in example 4 :
 - Same as told for example 3.
 - Line 3, a quote mark isn't escape and an other is missing at the end.

See attached code for more details.

Reproduce code:
---------------
Actual code for example 3 :

<?php
$format = 'Le %2\$s a %1\$d singes';
printf($format, $num, $location);
?>


Actual code for example 4 :

<?php
$format = 'Le %2\$s a %1\$d singes.
           C'est un beau %2$s, avec %1$d singes.;
printf($format, $num, $location);
?>


Expected result:
----------------
Expected example 3 :

<?php
$format = 'Le %2$s a %1$d singes';
printf($format, $num, $location);
?>


Expected example 4 :

<?php
$format = 'Le %2$s a %1$d singes.
           C\'est un beau %2$s, avec %1$d singes.';
printf($format, $num, $location);
?>



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-03-25 00:02 UTC] yannick@php.net
This bug has been fixed in the documentation's XML sources. Since the
online and downloadable versions of the documentation need some time
to get updated, we would like to ask you to be a bit patient.

Thank you for the report, and for helping us make our documentation better.


 [2020-12-30 12:50 UTC] nikic@php.net
Automatic comment on behalf of yannick
Revision: http://git.php.net/?p=doc/fr.git;a=commit;h=0664bb0301cfa201c2be9d1581a834e636c8272b
Log: sync with EN &amp; fix bug #44452
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu Dec 02 08:03:36 2021 UTC