php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #44435 [DE] German translation of CLI-Feature documentation has minor error
Submitted: 2008-03-14 10:06 UTC Modified: 2009-04-22 20:24 UTC
Votes:1
Avg. Score:2.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: juwe at clasennet dot de Assigned: wiesemann (profile)
Status: Closed Package: Translation problem
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: juwe at clasennet dot de
New email:
PHP Version: OS:

 

 [2008-03-14 10:06 UTC] juwe at clasennet dot de
Description:
------------
The german translation of the note behind overidden php.ini directives contains minor error.

The english version reads:
> Note: These directives cannot be initialized with another value 
> from the configuration file php.ini or a custom one (if specified). 
> This is a limitation because those default values are applied after 
> all configuration files have been parsed. However, their value can 
> be changed during runtime (which does not make sense for all of 
> those directives, e.g. register_argc_argv). 

While the current translated version says:
> Hinweis: Diese Direktiven k?nnen nicht mit einem anderen Wert aus
> der Konfigurationsdatei php.ini oder einer eigenen (falls 
> angegeben) initialisiert werden. Das ist eine Einschr?nkung, weil 
> diese Standardwerte angewandt werden, nachdem alle  
> Konfigurationsdateien durchlaufen wurden. Dennoch k?nnen die Werte 
> zur Laufzeit ver?ndert werden (was aber f?r alle diese Direktiven 
> keinen Sinn ergibt, beispielsweise register_argc_argv). 

Translated back into english this would say:
> Note: These directives cannot be initialized with another value 
> from the configuration file php.ini or a custom one (if specified). 
> This is a limitation because those default values are applied after 
> all configuration files have been parsed. However, their value can 
> be changed during runtime (which does not make sense for any of 
> these directives, e.g. register_argc_argv). 

Could you please fix the documentation? 

Suggested fix:

Hinweis: Diese Direktiven k?nnen nicht mit einem anderen Wert aus der Konfigurationsdatei php.ini oder einer eigenen (falls angegeben) initialisiert werden. Das ist eine Einschr?nkung, weil diese Standardwerte angewandt werden, nachdem alle Konfigurationsdateien durchlaufen wurden. Dennoch k?nnen die Werte zur Laufzeit ver?ndert werden (was aber nicht f?r alle dieser Direktiven einen Sinn ergibt, beispielsweise register_argc_argv). 



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-04-22 20:24 UTC] wiesemann@php.net
This bug has been fixed in the documentation's XML sources. Since the
online and downloadable versions of the documentation need some time
to get updated, we would like to ask you to be a bit patient.

Thank you for the report, and for helping us make our documentation better.


 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Mon Nov 29 00:03:13 2021 UTC