php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #44401 mbstring.func_overload doesn't overload strtolower() and strtoupper() functions
Submitted: 2008-03-10 23:44 UTC Modified: 2008-03-11 01:57 UTC
From: seza at paradoxal dot org Assigned:
Status: Closed Package: mbstring related
PHP Version: 5.2.5 OS: Debian Etch, php 5.2.0-8+etch10
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: seza at paradoxal dot org
New email:
PHP Version: OS:

 

 [2008-03-10 23:44 UTC] seza at paradoxal dot org
Description:
------------
When mbstring.func_overload set to 1. strtolower() and strtoupper() functions are not replaced by mb_strtolower() and mb_strtoupper() functions.

I saw that when I would lower case french text with ? and ? caracter. In my php.ini mbstring.func_overload is enabled and I use internal encoding UTF-8. 

Use strtolower with a french utf-8 text don't work but mb_strtolower work !




Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-03-11 01:49 UTC] s dot masugata at digicom dot dnp dot co dot jp
Hello.

http://jp.php.net/manual/en/ref.mbstring.php#mbstring.overload

Please set mbstring.func_overload = 2.

mbstring.func_overload = 1 is only mail function overload.

Thank you.
 [2008-03-11 01:57 UTC] seza at paradoxal dot org
Thanks for your comment.

It's me and not a bug.

I close it.

Thanks.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sat Mar 02 01:01:28 2024 UTC