php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #44234 call to undefined function mssql_connect()
Submitted: 2008-02-24 11:51 UTC Modified: 2008-02-24 19:14 UTC
From: adamgeoffrey12 at yahoo dot com Assigned:
Status: Not a bug Package: MSSQL related
PHP Version: 5.2.5 OS: win xp sp2
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: adamgeoffrey12 at yahoo dot com
New email:
PHP Version: OS:

 

 [2008-02-24 11:51 UTC] adamgeoffrey12 at yahoo dot com
Description:
------------
im using iis,sql server 2005 and php 5.2.5
the php_mssql.dll extension is already uncommented in php.ini of php 5.2.5 win 32 installer, i have put the php_mssql.dll and ntwdblib.dll in system 32 and php\:extension folders the fatal error call to undefined function mssql_connect() still comes. 
 testing for availability of php functions using;-
<?php
if (function_exists('mssql_connect')) {
	echo "Okay, fn is there";
} else {
	echo "Hmmm .. fn is not even there";
}
 ?>
it returns the else part, where the problem will be??plz help me i have suffered this problem for months.  

Reproduce code:
---------------
the code i used to connect to the database is as follows;-
<?php
$dbserver="localhost, 1433";
$dbuser="sa";
$dbpass="adam";
$dbname="Student";
?>
then
<?php
$dbconn=mssql_connect($dbserver,$dbuser,$dbpass);
mssql_select_db($dbname, $dbconn) or die("Unable to Open The Database");
?>


Expected result:
----------------
to connect to sql server, unfortunately i couldnt, plz plz help me out of this big problem.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-02-24 19:14 UTC] msaraujo@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 [2011-12-07 06:44 UTC] rubia_mit09 at yahoo dot com
i have a problem in connectivity php with mssql the error is "undefined function 
mssql_connect() " at local host please tell me solution....
 [2011-12-07 08:23 UTC] rubia_mit09 at yahoo dot com
i have a mssql server 2000, and want to connect with php at localhost but the 
error is"undefined function mssql_connect()" and i have also configure php.ini 
file but error still remaining kindly tell me solution of that error
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sat Dec 03 12:03:44 2022 UTC