php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #44161 can't run php on vista ultimate
Submitted: 2008-02-18 19:50 UTC Modified: 2008-03-13 12:28 UTC
Votes:2
Avg. Score:4.0 ± 1.0
Reproduced:2 of 2 (100.0%)
Same Version:2 (100.0%)
Same OS:2 (100.0%)
From: ankushbadyal at aol dot in Assigned:
Status: Not a bug Package: IIS related
PHP Version: 5.2.5 OS: windows vista ultimate
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: ankushbadyal at aol dot in
New email:
PHP Version: OS:

 

 [2008-02-18 19:50 UTC] ankushbadyal at aol dot in
Description:
------------
The page you are requesting cannot be served because of the Multipurpose Internet Mail Extensions (MIME) map policy that is configured on the Web server. The page you requested has a file name extension that is not recognized, and is not allowed. 
Error Code: 0x80070032 

Notification: ExecuteRequestHandler 

Module: StaticFileModule 

Requested URL: http://localhost:80/abc.php 

Physical Path: C:\inetpub\wwwroot\abc.php 

Logon User: Anonymous 

Logon Method: Anonymous 

Handler: StaticFile 
Most likely causes: 

It is possible that a handler mapping is missing. By default, the static file handler processes all content. 
The feature you are trying to use may not be installed. 
The appropriate MIME map is not enabled for the Web site or application. (Warning: Do not create a MIME map for content that users should not download, such as .ASPX pages or .config files.) 
What you can try: 

In system.webServer/handlers: 
Ensure that the expected handler for the current page is mapped. 
Pay careful attention to preconditions (e.g. runtimeVersion, pipelineMode, bitness) and compare them to the settings for your application pool. 
Pay careful attention to typographical errors in the expected handler line. 
Please verify that the feature you are trying to use is installed. 
Verify that the MIME map is enabled or add the MIME map for the Web site using the command-line tool appcmd.exe. 
Open a command prompt and change directory to %windir%\system32\inetsrv. 
To set a MIME type, use the following syntax: appcmd set config /section:staticContent /+[fileExtension='string',mimeType='string'] 
The variable fileExtension string is the file name extension and the variable mimeType string is the file type description. 
For example, to add a MIME map for a file which has the extension ".xyz", type the following at the command prompt, and then press Enter: 
appcmd set config /section:staticContent /+[fileExtension='.xyz',mimeType='text/plain'] 
Warning: Ensure that this MIME mapping is needed for your Web server before adding it to the list. Configuration files such as .CONFIG or dynamic scripting pages such as .ASP or .ASPX, should not be downloaded directly and should always be processed through a handler. Other files such as database files or those used to store configuration, like .XML or .MDF, are sometimes used to store configuration information. Determine if clients can download these file types before enabling them. 
Create a tracing rule to track failed requests for this HTTP status code. For more information about creating a tracing rule for failed requests, click here. 
More Information... This error occurs when the file extension of the requested URL is for a MIME type that is not configured on the server. You can add a MIME type for the file extension for files that are not dynamic scripting pages, database, or configuration files. Process those file types using a handler. You should not allows direct downloads of dynamic scripting pages, database or configuration files. 


--------------------------------------------------------------------------------
Server Version Information: Internet Information Services 7.0. 



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-03-13 12:28 UTC] jani@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

.
 [2011-10-09 03:29 UTC] tadehdavtian at yahoo dot com
http://localhost/phpinfo.php

Server Error in Application "DEFAULT WEB SITE"


Internet Information Services 7.5



Error Summary
HTTP Error 404.3 - Not Found

The page you are requesting cannot be served because of the extension configuration. If the page is a script, add a handler. If the file should be downloaded, add a MIME map.


Detailed Error Information



Module

StaticFileModule



Notification

ExecuteRequestHandler



Handler

StaticFile



Error Code

0x80070032





Requested URL

http://localhost:80/phpinfo.php



Physical Path

C:\inetpub\wwwroot\phpinfo.php



Logon Method

Anonymous



Logon User

Anonymous




Most likely causes:•It is possible that a handler mapping is missing. By default, the static file handler processes all content.
•The feature you are trying to use may not be installed.
•The appropriate MIME map is not enabled for the Web site or application. (Warning: Do not create a MIME map for content that users should not download, such as .ASPX pages or .config files.)
•If ASP.NET is not installed.
 

Things you can try:•In system.webServer/handlers: ◦Ensure that the expected handler for the current page is mapped.
◦Pay extra attention to preconditions (for example, runtimeVersion, pipelineMode, bitness) and compare them to the settings for your application pool.
◦Pay extra attention to typographical errors in the expected handler line.

•Please verify that the feature you are trying to use is installed.
• Verify that the MIME map is enabled or add the MIME map for the Web site using the command-line tool appcmd.exe. 1.To set a MIME type, use the following syntax: %SystemRoot%\windows\system32\inetsrv\appcmd set config /section:staticContent /+[fileExtension='string',mimeType='string']
2.The variable fileExtension string is the file name extension and the variable mimeType string is the file type description.
3.For example, to add a MIME map for a file which has the extension ".xyz": appcmd set config /section:staticContent /+[fileExtension='.xyz',mimeType='text/plain']
 Warning: Ensure that this MIME mapping is needed for your Web server before adding it to the list. Configuration files such as .CONFIG or dynamic scripting pages such as .ASP or .ASPX, should not be downloaded directly and should always be processed through a handler. Other files such as database files or those used to store configuration, like .XML or .MDF, are sometimes used to store configuration information. Determine if clients can download these file types before enabling them. 
•Install ASP.NET.
•Create a tracing rule to track failed requests for this HTTP status code. For more information about creating a tracing rule for failed requests, click here. 
http://learn.iis.net/page.aspx/266/troubleshooting-failed-requests-using-tracing-in-iis-7/
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Wed Jul 24 20:01:28 2024 UTC