php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #44044 Error in exemple of trim function in the French documentation
Submitted: 2008-02-04 20:29 UTC Modified: 2008-03-07 20:19 UTC
From: j at darksage dot fr Assigned:
Status: Closed Package: Translation problem
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: j at darksage dot fr
New email:
PHP Version: OS:

 

 [2008-02-04 20:29 UTC] j at darksage dot fr
Description:
------------
Error in exemple of trim function in the French documentation.
http://fr.php.net/manual/fr/function.trim.php
The "Bonjour le monde !" text is badly trimmed.

Reproduce code:
---------------
$hello  = "Bonjour le monde !";
$trimmed = trim($hello, "Bjro");
var_dump($trimmed);

string(5) "nur le mnde !"

Expected result:
----------------
The correct result will be:

$hello  = "Bonjour le monde !";
$trimmed = trim($hello, "Bjro");
var_dump($trimmed);

string(5) "njour le monde !"


Or it is possible to put something like :

$hello  = "Bonjour le monde !";
$trimmed = trim($hello, "Bron !");
var_dump($trimmed);

string(5) "jour le monde"


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-03-07 20:19 UTC] yannick@php.net
This bug has been fixed in the documentation's XML sources. Since the
online and downloadable versions of the documentation need some time
to get updated, we would like to ask you to be a bit patient.

Thank you for the report, and for helping us make our documentation better.


 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Mon Aug 10 17:01:25 2020 UTC