php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #43972 PhD doesn't warn on missing partial IDs
Submitted: 2008-01-29 17:54 UTC Modified: 2008-01-29 18:55 UTC
From: gwynne@php.net Assigned: bjori (profile)
Status: Closed Package: Doc Build problem
PHP Version: Irrelevant OS: *
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: gwynne@php.net
New email:
PHP Version: OS:

 

 [2008-01-29 17:54 UTC] gwynne@php.net
Description:
------------
If build.php is given an invalid partial ID to render, no error message is produced.

Reproduce code:
---------------
$ phd -vvvvvvvv -d.manual.xml -psome.invalid.id


Expected result:
----------------
[00:00:00] ID 'some.valid.id' couldn't be found. Bailing.
$ echo $?
1
$ 

Actual result:
--------------
[00:00:00] Indexing...
[00:00:00] Indexing done
[00:00:00] Starting xhtml rendering
[00:00:00] Using the php theme (phpweb, chunkedhtml, bightml)
[00:00:00] Running partial build
[00:00:00] Finished rendering
$ echo $?
0
$ 

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-01-29 18:55 UTC] bjori@php.net
This bug has been fixed in CVS. Since the websites are not directly
updated from the CVS server, the fix might need some time to spread
across the globe to all mirror sites, including PHP.net itself.

Thank you for the report, and for helping us make PHP.net better.


 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Fri Jul 19 23:01:25 2019 UTC