php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #43945 wrong directory in require_once or file_exists calls
Submitted: 2008-01-26 12:43 UTC Modified: 2008-01-28 23:10 UTC
From: sysdev at gmx dot net Assigned:
Status: Not a bug Package: IIS related
PHP Version: 5.2.5 OS: Windows Server 2003
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: sysdev at gmx dot net
New email:
PHP Version: OS:

 

 [2008-01-26 12:43 UTC] sysdev at gmx dot net
Description:
------------
I have currently 3 virtual websites on my IIS 6 Box using the PHP5 SAPI (php5isapi.dll). Calls to require_once and file_exists (and maybe other functions) randomly succeed or fail.

I tracked down the problem by monitoring file access with FileMon and found that PHP tries to locate the files in the wrong directories: A call to require_once in Web1 for example results in a search for the file in the working directory of Web2.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-01-28 23:10 UTC] tony2001@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sun Jul 21 04:01:29 2024 UTC