php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #43842 register_globals randomise switching value On/Off
Submitted: 2008-01-14 16:54 UTC Modified: 2008-03-14 11:59 UTC
Votes:1
Avg. Score:4.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:0 (0.0%)
From: dan at eskhosting dot com Assigned:
Status: Not a bug Package: *Configuration Issues
PHP Version: 5.2.5 OS: Linux Red Hat ES 4
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: dan at eskhosting dot com
New email:
PHP Version: OS:

 

 [2008-01-14 16:54 UTC] dan at eskhosting dot com
Description:
------------
Set up value for gerister_globals take a random effect.

Reproduce code:
---------------
php.ini:
register_globals = Off

.htaccess:
php_flag register_globals On





Expected result:
----------------
register_globals On

Actual result:
--------------
<? 
 phpinfo();
?>
reports:

register_globals On/Off - randomise!

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-01-14 17:05 UTC] dan at eskhosting dot com
Apache 1.3.37 PHP as module.
5.2.3 worked without this problem..
 [2008-01-15 09:05 UTC] dan at eskhosting dot com
See here: http://blog.nefedov.org/phpinfo.php
Now php.ini value is On. In .htaccess - Off.

Local Master
On    On
Off   On
Off   On
Off   On
On    On
On    On
On    On
Off   On
Off   On
On    On
On    On
On    On
On    On
On    On
On    On
Off   On
On    On
Off   On
On    On
(interval - 1 min)
 [2008-01-28 23:36 UTC] tony2001@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

Not PHP, but Apache problem.
 [2008-03-14 11:59 UTC] jani@php.net
Or maybe it wasn't. Possibly fixed in CVS now.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sun Aug 14 01:05:46 2022 UTC