php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #43806 Unexpected result using 'foreach'
Submitted: 2008-01-10 11:25 UTC Modified: 2008-01-10 12:22 UTC
From: pepalegre at terra dot es Assigned:
Status: Not a bug Package: Arrays related
PHP Version: 5.2.5 OS: openSUSE 10.3
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: pepalegre at terra dot es
New email:
PHP Version: OS:

 

 [2008-01-10 11:25 UTC] pepalegre at terra dot es
Description:
------------
If I declare a reference variable (&$value) and use it in a 'foreach' and then I reuse it in the same loop like a normal variable ($value), I have an unexpected result, array is modified!
Note that using another variable in the second 'foreach' the result is Ok.


Reproduce code:
---------------
<?php
        $v = array (1,2,3);
        foreach($v as &$value);
        print_r($v);
        foreach($v as $value);
        print_r($v);
?>


Expected result:
----------------
Array
(
    [0] => 1
    [1] => 2
    [2] => 3
)
Array
(
    [0] => 1
    [1] => 2
    [2] => 3
)


Actual result:
--------------
Array
(
    [0] => 1
    [1] => 2
    [2] => 3
)
Array
(
    [0] => 1
    [1] => 2
    [2] => 2
)


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-01-10 12:22 UTC] derick@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

(This has also been submitted a few times too)
 
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Wed Sep 27 14:01:25 2023 UTC