php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #43803 getting content-length:0
Submitted: 2008-01-10 07:41 UTC Modified: 2008-01-12 15:32 UTC
From: prabumfy at gmail dot com Assigned:
Status: Not a bug Package: cURL related
PHP Version: 4.4.8 OS: LInux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: prabumfy at gmail dot com
New email:
PHP Version: OS:

 

 [2008-01-10 07:41 UTC] prabumfy at gmail dot com
Description:
------------
Request Header:
-----------------------
Host: s3.amazonaws.com
Accept: */*
Date: Thu, 10 Jan 2008 06:45:42 GMT
Content-Length: 347
Authorization: AWS 10J23AYJKXBME657G7R2:eMvK...
Content-Length: 347
Expect: 100-continue

While uploading a file of 347bytes using PUT method the response header shows Content-Length: 0. but response code: 200 ok. If so getting content-length:0 is an error or not?
Yhanks Advance. Response Header is below.

HTTP/1.1 200 OK
Date: Thu, 10 Jan 2008 06:54:17 GMT
ETag: "36915b7d517a24a9521be305772479d3"
Content-Length: 0
Server: AmazonS3



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-01-12 15:32 UTC] tony2001@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Wed Oct 23 20:01:30 2019 UTC