php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #43761 fatal error: undefined functions: bcadd(), bcsub()
Submitted: 2008-01-05 19:49 UTC Modified: 2008-01-05 20:48 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: george dot girtsou at gmail dot com Assigned:
Status: Not a bug Package: BC math related
PHP Version: 5.2.5 OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: george dot girtsou at gmail dot com
New email:
PHP Version: OS:

 

 [2008-01-05 19:49 UTC] george dot girtsou at gmail dot com
Description:
------------
I get an undefined bcadd() function error on PHP 5.2.5.

"Fatal error: Call to undefined function bcadd() in <myfile> on line <line>"

On manual http://php.net/bcadd it says bcadd() function is supported in PHP 4 and PHP 5.

Thank you.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-01-05 20:12 UTC] george dot girtsou at gmail dot com
Just found that the problem is with both bcadd() and bcsub() functions.
 [2008-01-05 20:48 UTC] dsp@php.net
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.php.net/manual/ and the instructions on how to report
a bug at http://bugs.php.net/how-to-report.php

Please compile PHP with --enable-bcmath (and do a make distclean before, if needed). BCmath is disabled by default (See Installation section in the bcmath php.net manual pages)
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sat Mar 06 14:01:22 2021 UTC