php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #43756 ob_get_contents() ignores the first new line after ?>
Submitted: 2008-01-05 01:18 UTC Modified: 2008-01-05 02:51 UTC
From: aleast at capri dot it Assigned:
Status: Not a bug Package: Output Control
PHP Version: 5.2.5 OS: Linux Ubuntu 7.10
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: aleast at capri dot it
New email:
PHP Version: OS:

 

 [2008-01-05 01:18 UTC] aleast at capri dot it
Description:
------------
ob_get_contents() ignores the first new line after ending php tag ?>.

Reproduce code:
---------------
<?php ob_start(); ?>
a
<?php

$content = ob_get_contents();
ob_end_clean();

for ($i = 0; $i < strlen($content); $i++) {
    echo ord($content[$i])."\n";
}

?>

Expected result:
----------------
10
97
10

Actual result:
--------------
97
10

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-01-05 02:51 UTC] johannes@php.net
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.php.net/manual/ and the instructions on how to report
a bug at http://bugs.php.net/how-to-report.php

.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Tue Apr 16 20:01:31 2024 UTC