php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #43680 OnUpdateUTF8String problems in PHP 6
Submitted: 2007-12-26 19:36 UTC Modified: 2008-01-15 17:10 UTC
From: christopher dot jones at oracle dot com Assigned:
Status: Closed Package: Unicode Engine related
PHP Version: 6CVS-2007-12-26 (CVS) OS: n/a
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
45 - 20 = ?
Subscribe to this entry?

 
 [2007-12-26 19:36 UTC] christopher dot jones at oracle dot com
Description:
------------
Problem reported to me as:

 > The problems I faced when unicode.semantics=On were:
 >
 > 1) Any OnUpdateUTF8String php.ini variable is seen as NULL in
 > oci_globals.
 >
 > 2) If the above is resolved, the memory of the variable is wiped out,
 > by the time we come to execution of the script, after module inits.
 >
 > 3) We still convert to UTF-16 when unicode.semantics=Off.


Patch is in: http://news.php.net/php.internals/32817

Andrei was OK with the change: http://news.php.net/php.internals/32949


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-01-15 17:10 UTC] tony2001@php.net
This bug has been fixed in CVS.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.
 
Thank you for the report, and for helping us make PHP better.

Committed =)
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sat Jul 20 03:01:26 2019 UTC