php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #43671 Problem with converting utf-8 to cp1251
Submitted: 2007-12-25 02:07 UTC Modified: 2007-12-25 10:16 UTC
From: svimik at mail dot ru Assigned:
Status: Not a bug Package: ICONV related
PHP Version: 5.2.5 OS: Windows Server 2003
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: svimik at mail dot ru
New email:
PHP Version: OS:

 

 [2007-12-25 02:07 UTC] svimik at mail dot ru
Description:
------------
I found a problem with symbol \xC2\xB4
In text editors this symbol looks like "`".
But iconv() stops converting at this symbol.
The code is below.
It returns "Soil" instead of "Soil?s Song".

Reproduce code:
---------------
echo iconv('utf-8', 'cp1251', "Soil\xC2\xB4 Song");

Expected result:
----------------
Soil

Actual result:
--------------
Soil`s Song

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-12-25 02:09 UTC] svimik at mail dot ru
I have found a problem with symbol \xC2\xB4
In text editors this symbol looks like "`".
But iconv() stops converting at this symbol.
The code is below.
It returns "Soil" instead of "Soil?s Song".
 [2007-12-25 10:16 UTC] derick@php.net
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.php.net/manual/ and the instructions on how to report
a bug at http://bugs.php.net/how-to-report.php

That's because the "U+00B4 ACUTE ACCENT" character is not part of cp1251. It is a different character than "U+0060 GRAVE ACCENT".
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu Sep 16 22:03:37 2021 UTC