php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #43652 zip compression direct output
Submitted: 2007-12-21 13:08 UTC Modified: 2020-03-29 05:13 UTC
Votes:6
Avg. Score:3.7 ± 0.9
Reproduced:6 of 6 (100.0%)
Same Version:4 (66.7%)
Same OS:3 (50.0%)
From: goetas at lignano dot it Assigned:
Status: Wont fix Package: Zip Related
PHP Version: 5.6.11 OS: *
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: goetas at lignano dot it
New email:
PHP Version: OS:

 

 [2007-12-21 13:08 UTC] goetas at lignano dot it
Description:
------------
trying to create a zip file directly on standard output

Reproduce code:
---------------
$zip = new ZipArchive();
$zip->open("php://output", ZIPARCHIVE::CREATE);
$zip->addFromString("testfile.txt", "This is a test");
$zip->close();

Expected result:
----------------
i expect a zip file sent on standard output

Actual result:
--------------
no output

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-12-21 14:13 UTC] pajoye@php.net
Zip streams in write mode are not yet supported. I'm working on a stream abstraction layer for the underlying library.
 [2009-03-23 21:19 UTC] fin dot bub at gmail dot com
Same problem stays in 5.2.9.
 [2010-12-20 14:24 UTC] jani@php.net
-Package: Feature/Change Request +Package: Zip Related
 [2015-07-17 10:35 UTC] cmb@php.net
-Operating System: Windows XP/Slackware +Operating System: * -PHP Version: 5.2.5 +PHP Version: 5.6.11
 [2017-10-24 07:37 UTC] kalle@php.net
-Status: Assigned +Status: Open -Assigned To: pajoye +Assigned To:
 [2020-03-18 13:39 UTC] remi@php.net
-Status: Open +Status: Feedback
 [2020-03-18 13:39 UTC] remi@php.net
Propose to close as wont fix,

Not doable for now
 [2020-03-29 04:22 UTC] php-bugs at lists dot php dot net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Re-Opened". Thank you.
 [2020-03-29 05:13 UTC] requinix@php.net
-Status: No Feedback +Status: Wont fix
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sat Dec 05 12:01:22 2020 UTC