php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #43605 500 Internal Server error
Submitted: 2007-12-15 22:01 UTC Modified: 2007-12-15 22:19 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: aldenpease963 at peaseenterprises dot com Assigned:
Status: Not a bug Package: PHP options/info functions
PHP Version: 6CVS-2007-12-15 (snap) OS: Windows XP SP2
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: aldenpease963 at peaseenterprises dot com
New email:
PHP Version: OS:

 

 [2007-12-15 22:01 UTC] aldenpease963 at peaseenterprises dot com
Description:
------------
I am using PHP 6 Snapshot and Apache HTTPd Server 2.2.6.  I am also using MySQL 4.1.  I am using the web program PHPBTTracker+ (phpbttrkplus.sf.net), a p2p program.  I go to upload a torrent it it leads me to "Error code 500, Internal Server Error" and wont let me upload anything.  I contacted them and they said it was my php.ini, so I looked through my php.ini file and can't find a problem.  If you know how to fix this problem email me at aldenpease963@peaseenterprises.com.  I also tried to install Blog 2 Evolution and Zen Cart and it did the same thing when uploading stuff.

Reproduce code:
---------------
It is too long, you can view it at http://12.148.233.90/administration/bta_add.php

Expected result:
----------------
It to upload my torrent I selected on the previous page.

Actual result:
--------------
[Sat Dec 15 16:36:48 2007] [notice] Child 3540: Child process is exiting
[Sat Dec 15 16:36:49 2007] [notice] Apache/2.2.2 (Win32) PHP/6.0.0-dev configured -- resuming normal operations
[Sat Dec 15 16:36:49 2007] [notice] Server built: Apr 29 2006 18:32:31
[Sat Dec 15 16:36:49 2007] [notice] Parent: Created child process 4604
[Sat Dec 15 16:36:49 2007] [notice] Child 4604: Child process is running
[Sat Dec 15 16:36:49 2007] [notice] Child 4604: Acquired the start mutex.
[Sat Dec 15 16:36:49 2007] [notice] Child 4604: Starting 250 worker threads.
[Sat Dec 15 16:36:49 2007] [notice] Child 4604: Starting thread to listen on port 80.
[Sat Dec 15 16:39:23 2007] [error] an unknown filter was not added: deflate
[Sat Dec 15 16:39:31 2007] [error] [client 12.148.233.90] PHP Notice:  Undefined index:  add in C:\\server\\htdocs\\administration\\bta_funcs.php on line 241
[Sat Dec 15 16:39:31 2007] [error] [client 12.148.233.90] PHP Notice:  Undefined index:  retiredmgmt in C:\\server\\htdocs\\administration\\bta_funcs.php on line 246
[Sat Dec 15 16:39:31 2007] [error] [client 12.148.233.90] PHP Notice:  Undefined index:  ipban in C:\\server\\htdocs\\administration\\bta_funcs.php on line 254
[Sat Dec 15 16:39:31 2007] [error] [client 12.148.233.90] PHP Notice:  Undefined index:  usermgmt in C:\\server\\htdocs\\administration\\bta_funcs.php on line 259
[Sat Dec 15 16:39:31 2007] [error] [client 12.148.233.90] PHP Notice:  Undefined index:  advsort in C:\\server\\htdocs\\administration\\bta_funcs.php on line 264
[Sat Dec 15 16:39:31 2007] [error] [client 12.148.233.90] PHP Notice:  Undefined index:  viewconf in C:\\server\\htdocs\\administration\\bta_main.php on line 311
[Sat Dec 15 16:39:33 2007] [error] [client 12.148.233.90] PHP Notice:  Undefined index:  add in C:\\server\\htdocs\\administration\\bta_add.php on line 85, referer: http://12.148.233.90/administration/bta_main.php
[Sat Dec 15 16:39:33 2007] [error] [client 12.148.233.90] PHP Notice:  Undefined index:  add in C:\\server\\htdocs\\administration\\bta_funcs.php on line 241, referer: http://12.148.233.90/administration/bta_main.php
[Sat Dec 15 16:39:33 2007] [error] [client 12.148.233.90] PHP Notice:  Undefined index:  retiredmgmt in C:\\server\\htdocs\\administration\\bta_funcs.php on line 246, referer: http://12.148.233.90/administration/bta_main.php
[Sat Dec 15 16:39:33 2007] [error] [client 12.148.233.90] PHP Notice:  Undefined index:  ipban in C:\\server\\htdocs\\administration\\bta_funcs.php on line 254, referer: http://12.148.233.90/administration/bta_main.php
[Sat Dec 15 16:39:33 2007] [error] [client 12.148.233.90] PHP Notice:  Undefined index:  usermgmt in C:\\server\\htdocs\\administration\\bta_funcs.php on line 259, referer: http://12.148.233.90/administration/bta_main.php
[Sat Dec 15 16:39:33 2007] [error] [client 12.148.233.90] PHP Notice:  Undefined index:  advsort in C:\\server\\htdocs\\administration\\bta_funcs.php on line 264, referer: http://12.148.233.90/administration/bta_main.php
[Sat Dec 15 16:39:42 2007] [error] [client 12.148.233.90] PHP Notice:  Undefined index:  add in C:\\server\\htdocs\\administration\\bta_add.php on line 85, referer: http://12.148.233.90/administration/bta_add.php
[Sat Dec 15 16:39:42 2007] [error] [client 12.148.233.90] PHP Fatal error:  Call to undefined function get_magic_quotes_gpc() in C:\\server\\htdocs\\administration\\bta_add.php on line 580, referer: http://12.148.233.90/administration/bta_add.php


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-12-15 22:05 UTC] aldenpease963 at peaseenterprises dot com
PHP Fatal error:  Call to undefined function get_magic_quotes_gpc() in C:\\server\\htdocs\\administration\\bta_add.php on line 580, referer: http://12.148.233.90/administration/bta_add.php

Looking into this.
 [2007-12-15 22:16 UTC] aldenpease963 at peaseenterprises dot com
I have fixed the problem, snapshots can't do the get_magic_quotes_gpc() function.
 [2007-12-15 22:19 UTC] derick@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

That\'s correct, we removed magic quotes in PHP 6.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Mon Aug 10 19:01:25 2020 UTC