|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #43592 error: utf8_mime2text() has new signature, but U8T_CANONICAL is missing
Submitted: 2007-12-14 01:50 UTC Modified: 2007-12-25 01:00 UTC
Avg. Score:4.0 ± 1.0
Reproduced:18 of 18 (100.0%)
Same Version:7 (38.9%)
Same OS:7 (38.9%)
From: will at willspc dot net Assigned:
Status: No Feedback Package: Compile Failure
PHP Version: 5.2.5 OS: Linux 2.6.9-55.0.6.EL
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please — but make sure to vote on the bug!
Your email address:
Solve the problem:
21 + 24 = ?
Subscribe to this entry?

 [2007-12-14 01:50 UTC] will at willspc dot net
5.2.5 does not build because it's missing the definition of
"U8T_CANONICAL" in the imap extension. 

I checked utf8.h on my system (buried in perl) and it does not have U8T_CANONICAL.

I'm using a CENTOS/BlueQuartz box, which uses a DoveCot implementation of imap.

Oddly enough, I originally tried using the exact configure command for 4.3.9, according to phpinfo (which was originally installed) and it did not build.  I'm having to install many libraries to get it to work.

Reproduce code:
./configure --build=i686-redhat-linux-gnu --host=i686-redhat-linux-gnu --target=i386-redhat-linux-gnu --program-prefix= --prefix=/usr --exec-prefix=/usr --bindir=/usr/bin --sbindir=/usr/sbin --sysconfdir=/etc --datadir=/usr/share --includedir=/usr/include --libdir=/usr/lib --libexecdir=/usr/libexec --localstatedir=/var --sharedstatedir=/usr/com --mandir=/usr/share/man --infodir=/usr/share/info --cache-file=../config.cache --with-config-file-path=/etc --with-config-file-scan-dir=/etc/php.d --enable-force-cgi-redirect --disable-debug --enable-pic --disable-rpath --enable-inline-optimization --with-bz2 --with-db4=/usr --with-curl --with-exec-dir=/usr/bin --with-freetype-dir=/usr --with-png-dir=/usr --with-gd=shared --enable-gd-native-ttf --without-gdbm --with-gettext --with-ncurses=shared --with-gmp --with-iconv --with-jpeg-dir=/usr --with-openssl --with-png --with-pspell --with-xml --with-expat-dir=/usr --with-dom=shared,/usr --with-dom-xslt=/usr --with-dom-exslt=/usr --with-xmlrpc=shared --with-pcre-regex=/usr --with-zlib=/usr --with-layout=GNU --enable-bcmath --enable-exif --enable-ftp --enable-magic-quotes --enable-sockets --enable-sysvsem --enable-sysvshm --enable-track-vars --enable-trans-sid --enable-yp --enable-wddx --with-pear=/usr/share/pear --with-imap=shared --with-imap-ssl --with-kerberos --with-ldap=shared --with-mysql=shared,/usr --with-pgsql=shared --with-snmp=shared,/usr --with-snmp=shared --enable-ucd-snmp-hack --with-unixODBC=shared,/usr --enable-memory-limit --enable-shmop --enable-calendar --enable-dbx --enable-dio --enable-mbstring=shared --enable-mbstr-enc-trans --enable-mbregex --with-mime-magic=/usr/share/file/magic.mime

Expected result:
I expect configure to succeed.

Actual result:
checking if your cpp allows macro usage in include lines... yes
checking for IMAP support... yes, shared
checking for IMAP Kerberos support... yes
checking for IMAP SSL support... yes
checking for utf8_mime2text signature... new
checking for U8T_CANONICAL... no
configure: error: utf8_mime2text() has new signature, but U8T_CANONICAL is missing. This should not happen. Check config.log for additional information.


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2007-12-17 10:02 UTC]
How did you install the c-client library? What OS are you using?
 [2007-12-25 01:00 UTC] php-bugs at lists dot php dot net
No feedback was provided for this bug for over a week, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
 [2008-08-13 09:54 UTC] tkevans at tkevans dot com
This error also occurs with Solaris 8 and PHP 4.4.9 (not seen in 4.4.7, the last version I successfully built).
 [2008-08-13 09:56 UTC] tkevans at tkevans dot com
Sorry, I meant Solaris 9, not Solaris 8.
 [2009-01-22 03:06 UTC] sean at choonz dot com
Yes, the same problem installing php-5.2.8 
Linux Redhat 2.6.18-xenU #1 SMP Thu Oct 4 12:23:41 BST 2007 x86_64 x86_64 x86_64 GNU/Linux

The last lines of config.log are:

configure:47185: checking for IMAP support
configure:47232: checking for IMAP Kerberos support
configure:47258: checking for IMAP SSL support
configure:47663:19: /mail.h: No such file or directory
configure:47682: checking for utf8_mime2text signature
configure:47700: gcc -c -I  conftest.c 1>&5
gcc: no input files
configure: failed program was:
#line 47687 "configure"
#include "confdefs.h"

#include <stdio.h>
#include <c-client.h>

int main() {

        SIZEDTEXT *src, *dst;
        utf8_mime2text(src, dst);

; return 0; }
configure:47729: checking for U8T_CANONICAL
configure:47745: gcc -c -I  conftest.c 1>&5
gcc: no input files
configure: failed program was:
#line 47734 "configure"
#include "confdefs.h"

#include <c-client.h>

int main() {

         int i = U8T_CANONICAL;

; return 0; }

I'm urgently trying to install php5 on my box but this is a blocker.
 [2009-01-22 03:15 UTC] sean at choonz dot com
So the way I fixed this on 5.2.8 was simply to run 
> sudo yum install libc-client-devel 
and configure again
and then it worked. hope this helps someone!
 [2014-08-06 10:52 UTC] john dot lupa at gmail dot com
I would add that this is not a singular case, there are A LOT of CONFUSING error messages when trying to do a PHP custom compilation; the configure script is spitting out weird error messages that don't seem related to the real problem. A review of the process would be actually nice.
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Fri Sep 22 22:01:24 2023 UTC