php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #43591 strange value for sendmail_path if configure can't find sendmail
Submitted: 2007-12-13 22:01 UTC Modified: 2007-12-25 00:35 UTC
From: jholmes at tvmedia dot ca Assigned:
Status: Not a bug Package: Mail related
PHP Version: 5.2.5 OS: Linux 2.6.18
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: jholmes at tvmedia dot ca
New email:
PHP Version: OS:

 

 [2007-12-13 22:01 UTC] jholmes at tvmedia dot ca
Description:
------------
The default value for configuration option 'sendmail_path' is not sane.

In previous versions of php, the default value was '/usr/sbin/sendmail -t -i ' which should work on most *nix systems

Since I've upgraded to 5.2.5, the default value is '-t -i ', which isn't going to work on anything.

PHP was compiled from source on this system.

Reproduce code:
---------------
From the command line (ditto for SAPI module): 

linux:~# echo "<?php var_dump(ini_get('sendmail_path')); ?>" | php -n


Expected result:
----------------
string(25) "/usr/sbin/sendmail -t -i "

Actual result:
--------------
string(7) " -t -i "

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-12-22 11:10 UTC] johannes@php.net
Was the sendmail binary somewhere in the path during your configure run and set as executable for the user running configure?
 [2007-12-22 16:14 UTC] jholmes at tvmedia dot ca
That must have been the problem. I checked my Makefile and PROG_SENDMAIL had no value. After checking to make sure sendmail was in my path, I ran ./configure again and now PROG_SENDMAIL is set correctly.

Still, if configure can't find sendmail it shouldn't set sendmail_path to just the switches (" -t -i ").  I think this might have something to do with bug #42505.
 [2007-12-25 00:35 UTC] johannes@php.net
In PHP 4.2.0, the 'register_globals' setting default changed to
'off'. See http://www.php.net/release_4_2_0.php for more info.
We are sorry about the inconvenience, but this change was a necessary
part of our efforts to make PHP scripting more secure and portable.

No real issue, just a problem with the bad default which was reported before.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu Oct 28 12:03:36 2021 UTC