php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #43560 CGI Error on IIS 6.0
Submitted: 2007-12-11 06:14 UTC Modified: 2007-12-11 10:54 UTC
From: bluemoon dot kmutt at gmail dot com Assigned:
Status: Not a bug Package: IIS related
PHP Version: 5.2.5 OS: Windows Server 2003
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: bluemoon dot kmutt at gmail dot com
New email:
PHP Version: OS:

 

 [2007-12-11 06:14 UTC] bluemoon dot kmutt at gmail dot com
Description:
------------
System Spec:
Windows Server 2003
IIS 6.0
PHP 5.2.5
------
I have been create website and distributed.
Website can used and display with no error. Then few days ago
my website display some following error 

---
CGI Error
The specified CGI application misbehaved by not returning a complete set of HTTP headers.
---

I don't know what happened.
So I copy all of file to another drive and re-distribute it and map to
the same website and recheck it, it can display with no above error.
And then I rebuild it on the same drive that occur and error with difference folder name, it display error again.So I install Apache Web server and map to the same folder. No error display with Apache web server. Anybody can help me to fix this problem?

Thank you so much for you help.

Reproduce code:
---------------
<?
// Just this simple souce code, it display an error.
phpinfo();
?>

Expected result:
----------------
CGI Error
The specified CGI application misbehaved by not returning a complete set of HTTP headers.

Actual result:
--------------
Output as the PHP Infomation Page.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-12-11 10:54 UTC] jani@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Wed Jul 24 21:01:28 2024 UTC