php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #43469 Extensions Problem
Submitted: 2007-12-01 11:28 UTC Modified: 2007-12-03 11:09 UTC
From: juice777 at hotmail dot co dot uk Assigned:
Status: Not a bug Package: IIS related
PHP Version: 5.2.5 OS: Windows Server 2003 Web Edition
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: juice777 at hotmail dot co dot uk
New email:
PHP Version: OS:

 

 [2007-12-01 11:28 UTC] juice777 at hotmail dot co dot uk
Description:
------------
I have installed the latest version of PHP (5.2.5) on to a Microsoft Windows Server 2003 Web Edition OS (IIS 6.0) using the Windows Installer. I initially decided to run PHP in CGI Mode, but this did not work, so I ran the installer again and selected ISAPI mode, I changed the following in IIS to get PHP to work:

-	Web Sites Properties > Home Directory > Configuration > Mappings > .php Executable Path > C:\PHP\php5isapi.dll (changed from old DOS format path)

I could now get a .PHP file to display the output from phpinfo function.

Here?s the problem I have now:

Whilst running the Windows Installer I also added the GD2, Mysql and Mysqli extensions. I have checked the php.ini file and the appropriate .dll files have been uncommented and are present in the c:\php\ext directory. The problem now is that when I display the output of the phpinfo function, there is no mention of the above extensions in the output, which I am led to believe should be there. If I try using mysql_connect(), the function is not recognised.

I have read through most of the bugs relating to Server 2003, but I have yet to find any for Web Edition and have made sure that both my c:\php and c:\php\ext directories are on the path. Is there anything else I need to do?



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-12-03 11:09 UTC] jani@php.net
Check from phpinfo() output where PHP is trying to load php.ini from and which one it actually uses. This is not a bug, just wrong location for php.ini. 
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Wed Jul 24 22:01:28 2024 UTC