php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #43461 glob() returns false
Submitted: 2007-11-30 10:46 UTC Modified: 2007-12-02 16:06 UTC
From: marcin at artigo dot pl Assigned:
Status: Not a bug Package: Directory function related
PHP Version: 5.2.5 OS: Linux 2.6.21.5
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: marcin at artigo dot pl
New email:
PHP Version: OS:

 

 [2007-11-30 10:46 UTC] marcin at artigo dot pl
Description:
------------
glob() returns false instead of an empty array
No error occurs.

Reproduce code:
---------------
$ret = glob("*.foo");
var_dump($ret);

Expected result:
----------------
array
  empty


Actual result:
--------------
bool(false) 

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-11-30 10:56 UTC] jani@php.net
Please check bug #43407 as I believe this is the same issue, and not a bug.
 [2007-11-30 11:08 UTC] marcin at artigo dot pl
Directory exists, but glob finds no files.
If it considered an error why isn't it printed?

I believe it should return an empty array/display an error/or this issue should be documented here http://php.net/glob

We are talking here about Zend_Cache not working because of this.
 [2007-12-02 16:06 UTC] iliaa@php.net
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.php.net/manual/ and the instructions on how to report
a bug at http://bugs.php.net/how-to-report.php

If Zend_Cache does not work, it should be fixed.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu May 06 02:01:23 2021 UTC